This project is read-only.

Task Doesn't Work on Server 2

Oct 29, 2010 at 11:55 AM


I want to use the File Properties Task to simply get the last modification Date of a file i read later using a flat file source. (I do not need any other properties)

So i set up a file properties task:

File name source: static
File name: full file name incl. path

Properties: only Read modfied date/time  to a Variable of Data Type DateTime

This works great on my local machine.


Bute when i depoy the package to the server and run the package usin a SQL Agent Job, i get the following error:

12:43:45.17     Code: 0x00000000     Source: File Properties Task      Description: No variable is specified for the file name.  End Error  Error: 2010-10-29 12:43:45.17     Code: 0xC0024107     Source: File Properties Task      Description: There were errors during task validation.  End Error  DTExec: The package execution returned DTSER_FAILURE (1).  Started:  12:43:44  Finished: 12:43:45  Elapsed:  0.813 seconds.  The package execution failed.  The step failed.

(first i thought this is an permission issue, but running the package without the file properties task, it can read the file using a flat file source)


thanks for any help



Oct 29, 2010 at 12:06 PM

Hi Philipp,

Did you install File Property Task on Server? You need to install the file property task on server as well.



Oct 29, 2010 at 12:38 PM
Edited Oct 29, 2010 at 12:50 PM


yes, I installed the Task on the server (using the msi installer packge). Is there a possibility to check if the package was installed correctly?





just checked the .net 2.0 assembly chache, and i can find the FilePropertiesTask90 there


Oct 29, 2010 at 2:15 PM

Hi Philip,

I would suggest try to run this package individually. Do not run this from SQL Schedule Job. Lets see if it works without scheduling.

Did you create a installation setup i.e. msi?



Oct 29, 2010 at 9:27 PM

Hi again,

I tried to run the package individually (i created another package with a file property task only), but that did not work too.

I also tried to run the package from Business Intelligence Studio on the server, this works. (So i thing the task was installed correctly)

I did not create a installation setup for my package. I  just imported from File source using management Studio. I set the package protection level to "DontSaveSensitive", as with other settings  i had problems connetion to other datasources and flat files with default settings, but i don't think that has something to do with the problem)

I'll do some other tests on tuesday, as we have weekend until then and no SQL Server at home :).. Would be very fine if i get this task to work as it would save me lots of script tasks.. (I have to read approx. 50 different flat files, and i always have to add the last file modification date...)